Chatsie is compatible with old and new Android phones

Check which Android version you have, or view our recommended Android phones if you don’t have one already

PHONE VERSION

Find out which Android version you have

Chatsie works on your phone as long as it’s running Android 6.0 or later – this is over 90% of phones in use. To find out what version of Android is on your existing phone, you can look in settings or check online.

Option 1: Look in settings

Step 1

Open the Settings app on your Android phone

Step 2

Scroll down and select “About device” or “About phone”

Step 3

You should be able to see a heading that says “Android version” with the number. If you cannot see this yet, you may need to select “Software information” first.

Note: Some phones may show this information differently.

Option 2: Check online

Visit Whatismyandroidversion.com on your Android phone

RECOMMENDED PHONES

If you don’t have an existing Android phone we can suggest a few

Here are a couple of our recommended phones – all under $200. Don’t forget that you’ll also need a SIM Card.

Currently Chatsie only supports the English language.

Nokia 2.4

Buy on Amazon

Motorola Moto G8

Buy on Amazon